Slyck Chatbox - And More

If you have a linksys router read this...

This is the forum to discuss tech-hardware related issues.
Forum rules

If you have a linksys router read this...

Postby Progz » Mon Jan 02, 2006 6:57 pm ... GS_routers

Special note for users with Linksys WRT54G/GL/GS routers, there are severe problems with them when running any P2P app (read for fix)

The default firmware for Linksys (and all replacement firmwares except for one) have a severe problem where they track old connections for FIVE days, which causes the router to hang when using P2P apps, or any software that generates a lot of connections. DHT only aggravates the situation because of the number of connections it generates.

Linksys has yet to address this issue, but there is a fix. If you use alternative firmware, you can put in a start-up script to fix this problem. DD-WRT and HyperWRT support custom start-up scripts. I am not responsible if you screw up your router, so you do this at your own risk. This page has instructions on recovering a bricked router. For those using HyperWRT or willing to switch to it:

* HyperWRT2.1b1 tofu11 (54G/GL only, excluding hardware revision V5 of 54G) (does not require the following steps, but it can still improve performance over the firmware's defaults)
* DD-WRT v23 beta 2 (54G/GL/GS excluding hardware revision V5 of 54G) (requires the following steps)
* HyperWRT2.1b1 Thibor (54GS only) (requires the following steps)

You should avoid upgrading over a wireless connection, since the connection may drop out.

To upgrade the firmware, HyperWRT2.1b1 tofu11 or Thibor ONLY, follow the instructions on HyperWRT Manual - Installation
Note that tofu11 names the .bin file as code.bin, not hyperwrt*.bin

* Go to the web interface (default password is admin) by typing into your browser.
* Click Administration, then Edit Startup. Put the following commands in the box:

echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts
echo 1 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses
echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts

* Click Save, close the window, then click Save settings.
* Reboot the router (the Administration page has a Reboot button) and you'll be done.

To upgrade to DD-WRT, follow the instructions on this page. The Right Way to Flash Your WRT54G/GL/GS. The following instructions are for DD-WRT only

* Do not use the web interface method as it cuts off part of the commands.
* Enable SSH (Admin, Services) as we are going to use the NVRAM method @ ... RAM_Method
* Login to the router with an SSH client (root/your password).
* Put the following commands into the SSH client.

~ # nvram set rc_startup="
> echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts
> echo 1 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses
> echo '600 1800 120 60 120 120 10 60 30 120' > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts
> "
~ # nvram commit
~ # reboot
The system is going down NOW !!
Sending SIGTERM to all processes.

* Note the ' instead of " on the third command line. Using " on the third command line closes the set command (as on last line), meaning that the last command will get cut off prematurely.
* Make sure your "Maximum Ports" is set to 4096 on the Management page.
* You can check the settings worked by loggin in via SSH and viewing the contents of each fileas below or using the "nvram get rc_startup" command.

~ # more /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses

* Enjoy instant µTorrent speed increase from pretty much zero on each torrent to full speed!

Thanks frankw for the instructions for DD-WRT

Remember, I am not responsible if you screw up your router, so it's your problem if something goes wrong. However, if something does go wrong, this page has instructions on recovering a bricked ("dead") router.

If you require further assistance with either firmware, please visit (the main site does not have the latest builds however), HyperWRT Forum's Advanced Help Section,, and DD-WRT's Wiki.
Please do not ask for help with these firmwares on the µTorrent forums.

I have one but I seem to have my max speeds. Do I need to do this then? Im a bit confused.
Posts: 257
Joined: Sun Oct 02, 2005 3:32 pm

Postby IceCube » Mon Jan 02, 2006 8:10 pm

Hmm, I seem to have been beaten to this... oh well.

Port forwarding in eMule.

This helps as it tells you what port to forward to.

In the page under applicatios and gaming, you'll need to add these ports to the list in the order they appear in that page. In the application name, simply type in 'emule', 'emule2', 'emule3' and tick the 'enable' box right after it. Yes, it says 'from (port) to (port) but simply put the respective port in both boxes on the same line. Make sure you also have a static IP address or your IP may change and disable all of your efforts over time.

Confused? This link will help for the edonkey2000 app and will guide you through the rest of the steps (but remember, for eMule, you'll have to remember what was mentioned instead of the 'edonk1', etc. but if you use edonkey, I'm sure those steps specifically will resolve issues as well)

Also, you can look here for the original posting on me originally getting eMule up and running.

Another handy tip for your linksys router is that if you suddenly are unable to browse for unknown reason (even if you rerout your internet directly to your modum, etc.) try simply unplugging your linksys router from any power source (so that small black plug most likely) and wait about ten seconds, plug it back in and wait a moment and you might be allowed to browse again. This is how I resolved this problem when I lost all my internet capabilities even though my system tray said I was connected.

Edit: I don't use uTorrent, but perhapse something similar might be sufficient. You might need to get all the port information and make sure you disable the blocking of anonymous connections or else you might not be able to share or download anything.

Edit: I havn't tried getting BitTorrent up and running yet, but I have a feeling that once I have operated a little on my router, it'll be easier to simply add ports and apps to the list of enabled ports. These Linksys routers seem to be a royal pain in the neck for using p2p, but at least I didn't have to upgrade my firmware as of yet :)

Edit: I havn't editted my post enough yet, but if you are not experiencing any problems, I wouldn't touch the router settings. I'm quite sure its for users who can't either connect to trackers or can't get any upstream/downstream in any swarms.
User avatar
Posts: 17079
Joined: Tue Jun 14, 2005 5:31 pm
Location: Igloo Country?

Postby HouseCrowd » Tue Jan 03, 2006 9:01 am

Good posts you two!!! :)

I'll sticky this, but in the hardware section I think, since we already have a lot of stickies in 'General File-Sharing Discussion' ...
There are 10 types of people in the World; those who understand binary, and those who do not.
User avatar
Posts: 33862
Joined: Mon Oct 13, 2003 4:18 am
Location: UK

Postby LaX » Tue Jan 03, 2006 9:17 am

Thanks for that Progz and IceCube. But is reseting the router work whenever it hangs okay? I dont really wanna screw up the router firmware. If it doesnt work, I'm gonna get pretty screwed.

I have a linksys router if I didnt make it clear, but I can occasionally max out my download if there were enough seeds. I nearly always max out my upload speed too so do I actually need to do anything?
User avatar
Posts: 6551
Joined: Sun Oct 23, 2005 7:02 am
Location: One of the multiverses you're not in

Postby IceCube » Thu Jan 05, 2006 4:16 am

I wondered where this post went :lol:

If your not experienceing any problems, I wouldn't mess with the router settings. The only reason I started operating on my router was because my eMule suddenly always gave me 'LowID's on both KAD and on the regular servers as well as no connections from other peers at all (when typically I have a nice line going)

It's basically reconfiguring and forwarding some ports to make it work (not so much as if it works really great or just great) seems to be an awsome website for info on forwarding ports as well as making a static IP address. I havn't tried using the reset button as of yet as that never yielded results for me.

Any time the router 'hangs' its a simple matter of unplugging the thing, waiting ten seconds, then plugging it back in. A really good way to tell if something screwy is going on is double clicking on those two computers in your system tray (it represents your internet connection) and noting the packets sent and recieved. If it's kinda stopped for the most part between 0-400 packets recieved for quite a while, then you might be having that problem wherey ou need to unplug and replug in as you should be sending and recieving over a thousand packets within minutes.

For me, using a D-Link with a Telus connection, it also takes a few minutes for the modum to 'warm up' before it is able to do anything at all, so I have to give it time to do whatever it does before I can do anything online to begin with. :(
User avatar
Posts: 17079
Joined: Tue Jun 14, 2005 5:31 pm
Location: Igloo Country?

Postby poullos » Wed Jan 11, 2006 4:00 am

For BEFSX 41 the latest firmware has a bug with "Block anonymous WAN requests". To fix it search for the beta firmwares in the Linksys forums. I tried one of them(I will update this post when I go home and see the version) and it works now. It also adds Qos section for packet inspection priorities. For those not understanding what "Block anonymous WAN requests" is, you have to disable it to use upload speed sense in emule and autospeed plugin in azureus(you can bypass it in autospeed by forcing it use the ping command), and cfosspeed. Otherwise it disconnects your router from the net all the time. This enables the tracert.exe command to trace the route of the connection to a certain target and check the latency. If your latency is high upload speed sense and autospeed will automatically decrease your upload speed to decrease the latency. The result is optimal download speeds with the higher possible upload speeds. :wink:
User avatar
Posts: 1087
Joined: Fri Mar 19, 2004 9:29 am
Location: Mobile Server

Postby poullos » Wed Jan 11, 2006 2:55 pm

Edit: Firmware Version: 1.52.5_beta4

I get some disconnects with emule but I think this has to do with the new SP2 setup until I optimise the connections.
User avatar
Posts: 1087
Joined: Fri Mar 19, 2004 9:29 am
Location: Mobile Server

Postby Ratt » Thu Sep 21, 2006 5:18 am

If you have a cheap-ass D-Link router, for instance, then it's always possible you can forget about using KAD. Mine would auto-reboot every 5 minutes with KAD turned on. :shock:
User avatar
Posts: 951
Joined: Sun Mar 28, 2004 1:50 pm

Re: If you have a linksys router read this...

Postby peer2grifin » Mon Oct 11, 2010 8:32 am

as an update and an opinion, dd-wrt is the way to go. nowadays its easier to find the right one to install - and following the instructions, you should find yourself up and running in no time...the biggest piece of advice is to make sure that once you install the OS, WAIT 10 minutes before resetting/unplugging the device to get to the default dd-wrt screen

here is the updated list

also, here are the instructions for practically any good router
Posts: 10
Joined: Mon May 17, 2010 9:01 pm

Re: If you have a linksys router read this...

Postby zbeast » Mon Oct 11, 2010 12:55 pm

Well it's good to see that someone has investigated this, I've been having this trouble for years.
I'm usually aggravating my internet connection by running multiple p2p applications.
or if I want my connection to go down hard and fast and like right now.
I run Vuze.. it's seems to open way to many connections so my arp table overflows and crashes my dsl router.
Knowledge is power. Power corrupts. Study hard. Be evil.
Posts: 6783
Joined: Thu Apr 01, 2004 5:20 pm
Location: Behind that itch. yes, that one right there.

Return to Tech/Hardware Discussion

Who is online

Users browsing this forum: No registered users and 2 guests

© 2001-2008