Slyck.com
 
Slyck Chatbox - And More

Slow speeds at end of download with giganews, help!

Discussion about the binary newsgroups and how to successfully participate in the file-exchange
Forum rules
PLEASE READ BEFORE POSTING: Slyck Forum Rules

Slow speeds at end of download with giganews, help!

Postby Nuttyguy » Fri Dec 05, 2008 4:54 am

The strangest thing keeps happening. Near the end of a download, my download speed will slow to less than 50kB/s and cause the file to not finish downloading for a good 20-30 minutes. Last night I started downloading a 400mb file, usually this takes about 6 minutes to download, but I just got home from work (like 18 hours later) and it's still at 98% done. I've only ever had this issue with giganews. I've been with newshosting and usenetserver, and it never happened. This is my 2nd time with gigagnews (the retention keeps bringing me back) and I cancelled it the first time because of this exact issue. I can't find any information on it online. I use alt.binz as the reader, have tried the eurpoean giganews servers (same issue), tried the SSL 20 connections plan, and it still did the same thing. I just moved, I used to use Qwest DSL @ 7Mb/s, had the problem there, now I'm with Cableone @ 9Mb/s and still have the problem.

Anybody else ever have this issue?

Oh, and this is not an every file thing, sometimes it does it, sometimes it doesn't.

More info: It only lets one connection connect to the last "part", and that one connection will max out at 50kB/s, sometimes going a lot lower.

I'm all over the place, I hope I've explained the problem and maybe somebody can give me some insight. If I confused anyone, ask me questions, I'll try to explain things better.
User avatar
Nuttyguy
 
Posts: 598
Joined: Mon Mar 14, 2005 1:31 am
Location: Lewiston, ID

Re: Slow speeds at end of download with giganews, help!

Postby SleepyOne » Fri Dec 05, 2008 9:16 am

setup - connection - Retry count 1 - Delay 1 minute.

Only thing I can think of that would cause the effect you are describing would be that you are trying to download something where some parts are not on the server and you have set many retries and long delay between retries.

Just do as I described on the first line to shorten down the delay and let PAR do the rest.

If you are downloading something really big and several parts are missing, this will still lead to several minutes of "slowdown" at the end... in which case you should probably just set 0 on both to eliminate the retry completely.

As long as you aren't downloading stuff while its being uploaded, you won't really need the retry anyway.

In other words, change retry as needed :)
SleepyOne
 
Posts: 129
Joined: Fri May 12, 2006 1:22 pm

Re: Slow speeds at end of download with giganews, help!

Postby Nuttyguy » Sat Dec 06, 2008 6:08 pm

I set the retry and delay to 1, I've downloaded a few files, and the issue hasn't come up again, however, it didn't happen everytime anyway. Hopefully it worked, thanks for your help, I'll post again if it didn't fix it.
User avatar
Nuttyguy
 
Posts: 598
Joined: Mon Mar 14, 2005 1:31 am
Location: Lewiston, ID

Re: Slow speeds at end of download with giganews, help!

Postby scubascythan » Sat Dec 06, 2008 7:01 pm

I found with SSL my connections speed don't jump up as fast as non-SSL, probably due to server cpu usage allocated for each connection to encrypt the SSL (it does add up, on campus I max out the connection at around 10.2MByte/s cause newsleecher uses 100% of a P4 3.6Ghz).

Try starting out with lower connections, I find I can max out my home connection (7Mb/s) using 3 connections on Astraweb, so I set it normally to 6 anyways instead of 20.

Also, your file's 98% done and it's DLing at 50kB/s for the rest. Sounds like it's not a real major issue cause your getting your downloads anyways, you're just impatient...
scubascythan
 
Posts: 57
Joined: Wed Mar 23, 2005 2:05 pm

Re: Slow speeds at end of download with giganews, help!

Postby Nuttyguy » Mon Dec 08, 2008 5:29 am

you're just impatient...

:)
User avatar
Nuttyguy
 
Posts: 598
Joined: Mon Mar 14, 2005 1:31 am
Location: Lewiston, ID


Return to NewsGroups

Who is online

Users browsing this forum: No registered users and 3 guests

© 2001-2008 Slyck.com