Slyck.com
 
Slyck Chatbox - And More

G1 Host Cache/Discovery Services

Discussion of the Gnutella network and the Gnutella clients such as Gnucleus, XoloX, Shareaza, LimeWire and BearShare
Forum rules
PLEASE READ BEFORE POSTING: Slyck Forum Rules

G1 Host Cache/Discovery Services

Postby pogue » Sun Nov 26, 2006 11:58 pm

I'm using Shareaza 2.2.1.0 on XP SP2 and everything has been working fine. I'm connected to ed2k and G2, but lately, I've been having trouble finding live G1 connections. Does anyone know where I can find a list of live discovery services/bootstraps/hosts caches?

I am only aware of this site and haven't found any others that are still around.

Any help is appreciated. Thanks!
User avatar
pogue
 
Posts: 26
Joined: Mon Sep 19, 2005 2:59 am
Location: Texas

Postby LANjackal » Mon Nov 27, 2006 12:02 am

Upgrade to latest version (2.2.3.0 beta) at http://www.shareaza.com. Should fix your issues.
Follow me around the internet!
[Windows 7 Pro x64 (Primary OS)
User avatar
LANjackal
 
Posts: 5895
Joined: Thu Feb 26, 2004 1:58 pm
Location: Various networks. In the physical world I'm an adaptive AI that pretends to be human

Postby pogue » Mon Nov 27, 2006 12:08 am

LANjackal wrote:Upgrade to latest version (2.2.3.0 beta) at http://www.shareaza.com. Should fix your issues.


I have it downloaded, I just haven't installed it yet. But thanks for the tip. Next time I close Shareaza I'll upgrade to the latest.
User avatar
pogue
 
Posts: 26
Joined: Mon Sep 19, 2005 2:59 am
Location: Texas

Higher expiration date of G1 hosts

Postby sonnentier » Mon Nov 27, 2006 1:15 am

pogue, I recommend you to 'tweak' Shareaza's behaviour of chaching G1 nodes.

I found out, that everytime I didn't start Shareaza often, I still had a big list of Gnutella Hosts, but just when connecting, they were all flushed - without any attempt.
I was wondering why, because if this happens you have no single address and you need a webcache and these are rather slow and you shouldn't excessively use them, too.
I found out that the problem was pretty simple: I don't know for which reason, but Shareaza has the default setting that G1 nodes only last 2 Days or so - after that time, they aren't even checked anymore, just all deleted when connecting starts. Which kills the cache and you need theoretically then unneeded webcaches. While for G2 the expiration date is higher, for G1 it's a minimum.
I recommend you to higher the expiration, I don't see why you should delete them all before testing them. There are often stable static-IP nodes online all the time with which bootstrapping is fast and reliable.

To change the settings, open Preferences. Then, go to the advanced section at the bottom. Search for Gnutella.Hostexpire (or something like this), and change the setting which might be something like '2' to something like '30' or also '60', '90'.

After that, you only need to wait once that webcaches would tell you addresses, after that, in the very most cases, bootstrapping is fast because you can just try nodes in your cache.
User avatar
sonnentier
 
Posts: 160
Joined: Wed Sep 14, 2005 1:34 pm

Re: Higher expiration date of G1 hosts

Postby pogue » Mon Nov 27, 2006 1:49 am

sonnentier wrote:pogue, I recommend you to 'tweak' Shareaza's behaviour of chaching G1 nodes.

I found out, that everytime I didn't start Shareaza often, I still had a big list of Gnutella Hosts, but just when connecting, they were all flushed - without any attempt.
I was wondering why, because if this happens you have no single address and you need a webcache and these are rather slow and you shouldn't excessively use them, too.
I found out that the problem was pretty simple: I don't know for which reason, but Shareaza has the default setting that G1 nodes only last 2 Days or so - after that time, they aren't even checked anymore, just all deleted when connecting starts. Which kills the cache and you need theoretically then unneeded webcaches. While for G2 the expiration date is higher, for G1 it's a minimum.
I recommend you to higher the expiration, I don't see why you should delete them all before testing them. There are often stable static-IP nodes online all the time with which bootstrapping is fast and reliable.

To change the settings, open Preferences. Then, go to the advanced section at the bottom. Search for Gnutella.Hostexpire (or something like this), and change the setting which might be something like '2' to something like '30' or also '60', '90'.

After that, you only need to wait once that webcaches would tell you addresses, after that, in the very most cases, bootstrapping is fast because you can just try nodes in your cache.


Alright, I found exactly what you were talking about and the default was set at 2 days. I changed it to 30 days, so I'll see how that works out.

For anyone else having this issue currently or in the future, I've taken a screenshot of the setting and included it below.

Image
User avatar
pogue
 
Posts: 26
Joined: Mon Sep 19, 2005 2:59 am
Location: Texas


Return to Gnutella

Who is online

Users browsing this forum: No registered users and 1 guest

© 2001-2008 Slyck.com