Page 1 of 1

some problem with the firewall ?

PostPosted: Mon Dec 06, 2004 12:18 pm
by webSeeker10
Hi,
I am trying to get a primary connection, but impossible, the programm saying :
" No tcp port for incoming connections
No udp port for incoming and outgoing packets."

My firewall (F-Secure) is fitted with winMx task autorized, with the application+port on the out/client and the in/server.

What is wrong ?:cry: , and sorry for my bad english.

PostPosted: Mon Dec 06, 2004 12:36 pm
by Solomon
Try running the setup wizard again. Also, make sure that your router (if you have one) is set up correctly, and if you use XP, make sure the ICF is turned off.

PostPosted: Mon Dec 06, 2004 1:03 pm
by webSeeker10
Tx for reply
What is ICF ?

PostPosted: Mon Dec 06, 2004 3:30 pm
by Solomon
Internet Connection Firewall. A "feature" of XP to help keep your computer more secure.

Have a poke about in the settings of your internet connection. I think it says someting like "Protect this connection blah blah blah". Make sure the box is unticked.

PostPosted: Mon Dec 06, 2004 4:52 pm
by webSeeker10
The XP firewall is turned off.
I use a french freebox as modem.
The router fonction is fitted, with the 2 ports udp/6257 and tcp/6699.

PostPosted: Mon Dec 06, 2004 6:27 pm
by Solomon
So, ports are open on your end, through firewalls/routers?

Have you tried a different ISP? You might be able to find a free one on Google, like Juno. I dont know where in the world you are, but Im assuming it isnt somewhere where English is the native language, so make sure you find one that will work in your country.

Your ISP might be blocking ports, in which case a change will hopefully show up the differences.

You could also try changing the ports WinMX uses to connect with. Try adding a 1 in front of the numbers, making sure to reflect the changes in your router/firewall.

Did you run the setup wizard again?

PostPosted: Sun Dec 12, 2004 7:57 am
by webSeeker10
Hi,n
changing the #of ports, i can connect now with primary.
But the people who are in my Q can't UL from me.
They get a red colour, incomplete UL...
A week ago, they could UL from me, today, impossible ??
Really very strange
WinMX seems very instable, with this release (3.54 beta3)
All worked fine, with an old version, but i am wondering if the old versions can run, from the changing of version of WinMX....

PostPosted: Sun Dec 12, 2004 1:08 pm
by Solomon
The version you have is beta software, meaning it isnt fully tested, and there may be bugs. You can still use 3.53 to connect.

Uploads timing out means that you arent "fully connected". Somewhere along the line, transfers are being stopped by either a firewall or a router. Sort this out if you can. Did you change the numbers in the firewall/router to accept the new port numbers? Can they upload if you connect as Secondary?