Slyck.com
 
Slyck Chatbox - And More

Winmx & Billion 7500G Rouer

Discussion about the WinMX program/network
Forum rules
PLEASE READ BEFORE POSTING: Slyck Forum Rules

Winmx & Billion 7500G Rouer

Postby Locodriver » Mon Sep 13, 2004 1:27 am

Unable to get Winmx working with this router which has a Nat firewall. I have tried to set ports that is request but just will not work. I enjoyed using this program and want to use it again.
Locodriver
 
Posts: 12
Joined: Sat Sep 11, 2004 4:04 am

Postby Al » Wed Sep 15, 2004 4:14 pm

From what I can tell looking at the manual you need to do two things

1. forward the proper ports in the virtual server section of your router
2. If the packet filtering firewall in enabled in your router under configuration/firewall/general settings then you need to open the proper port filters in the configuration/firewall/packet filter section.


Firstly you can choose any port numbers you want to use for winmx in the winmx application configuration section. There is one setting that talks about inbound udp and one for tcp(don't use the same number for both udp and tcp).

Then:

You can access the router's web interface(assuming it is using defaults)
by typing the following address in your web browser

192.168.1.254
username admin
password admin


in section configuration/virtual server

you will need to create two rules, one for the udp port winmx uses and one for the tcp port

rule 1.
protocol tcp
external port(whatever number is set for tcp inbound in your winmx configuration, default is 6699)
redirect port same as external port number
ip address (the address of the machine you run winmx on)

You can find the ip address of that machine by running ipconfig from the command line of machine that runs winmx
For example under windows start menu start/run/ type ipconfig


MAKE SURE the enable checkbox is set to the left of the rule in the listing

rule 2.
rule 1.
protocol UDP
external port(whatever number is set for tcp inbound in your winmx configuration, default is 6257)
redirect port same as external port number
ip address (the address of the machine you run winmx on)

MAKE SURE the enable checkbox is set to the left of the rule in the listing


Note that if you have dhcp set on so your router dynamically assigns ip addresses to your machines it is possible that the ip of the machine you forward to will change which will break your port mapping rule. If this becomes a problem you can set up that machine for a static ip.
This likely won't be a problem but this link
http://www.dslwebserver.com/main/sbs-cr ... twork.html gives more info

THEN:

In your router packet filter section you need to create two rules: one for udp and one for tcp

configuration/firewall/packet filter

click port filter
click add tcp/udp filter

protocol type tcp
start port (whatever number is set for tcp inbound in your winmx configuration, the default is TCP 6699)
end port same as start port
inbound allow
outbound (you can allow this as well, though you shouldn't have to)


create another rule for udp (the default port for udp in winmx is 6257)

protocol type UDP
start port(udp setting for winmx)
end same as start
inbound allow
Al
 
Posts: 25
Joined: Mon Sep 06, 2004 10:16 pm


Return to WinMX

Who is online

Users browsing this forum: No registered users and 1 guest

© 2001-2008 Slyck.com